Update your browser to stay safe online

If you're seeing this message, you may need to update your browser.

Without the most up-to-date version of your browser, you may be more vulnerable to cybersecurity threats, such as viruses and ransomware.

You also may have problems viewing our latest site features, as Telstra's website does not support outdated browsers. Find out more about staying safe online.

When you need IPSec, PPTP, SSL or SSH VPNs for secure tunnelling over public networks, we can help you select the solution that brings you performance and security.