Update your browser to stay safe online

If you're seeing this message, you may need to update your browser.

Without the most up-to-date version of your browser, you may be more vulnerable to cybersecurity threats, such as viruses and ransomware.

You also may have problems viewing our latest site features, as Telstra's website does not support outdated browsers. Find out more about staying safe online.

Before you start

You’ll need:

  • The latest version of the Alexa app
  • An Australian Amazon account
  • A compatible mobile device or tablet that;
    1. supports a 2.4GHz or 5GHz connection
    2. has the minimum requirements to run the Alexa app
  • An internet connection
  • A secure Wi-Fi network and your Wi-Fi password.

Good to know

  • WPA2-Enterprise networks are not supported.

To activate your Amazon Echo or Echo Dot:

 

 

 

 

Still need to get in touch

CrowdSupport®

Have a question? Ask our Customer Forum.

Go to CrowdSupport
24x7 Chat

Chat with us now.

 

Chat Now
Contact us

Prefer to talk to someone over the phone? We're here to answer your questions.

Contact us
Find a store

Find your nearest Telstra store or Wi-Fi hotspot.

Find a store